Excel – Funkcje odnoszące się do zamkniętych plików

Piotr Majcher Excel 10 Comments

Prawie wszystkie funkcje programu Excel mogą bez problemów odwoływać się do innych plików (skoroszytów) nawet gdy pliki te są zamknięte.

Niestety są pewne wyjątki. Niektóre funkcje obsługują odwołania do zakresów z innych plików ale nie działają poprawnie jeśli pliki do których się odwołują są zamknięte.

W tym filmie pokazuję taki przypadek na przykładach bardzo popularnych funkcji liczących i sumujących warunkowo.

Pokazuję także sposób na obejście tego problemu.

Użyta/e funkcja/e: LICZ.JEŻELI, SUMA.ILOCZYNÓW, LICZ.WARUNKI, SUMA.JEŻELI, SUMA.WARUNKÓW

 

Pobierz plik do filmu: http://www.pmsocho.com/pobierz-pliki-do-filmow

Nazwa pliku: excel-770 – Funkcje odnoszące się do zamkniętych plików.xlsx

 

Comments 10

  1. Świetna robota. Po raz kolejny korzystam z Pańskich poradników. W tym konkretnym przypadku myślałem, że polegnę (LICZ.JEŻELI) i praca na zamkniętym pliku = no can do. A tutaj wszystko jak zwykle dokładnie i precyzyjnie wytłumaczone.
    Podziwiam pasję do tego typu rzeczy 🙂

    1. Post
      Author
  2. Staram się robić zgodnie z instrukcją i plikiem, ale coś mi nie wychodzi…
    Formuła wygląda jak niżej, co robię źle? Odniesienie nadal działa tylko do otwartego pliku źródłowego, przy zamknietym jest #ADR…

    =WYSZUKAJ.PIONOWO($A3;ADR.POŚR(ZŁĄCZ.TEKSTY(„‚\\192.100.100.100\katalog\podkatalog\[Raport_”;$A$1;”.xlsx]”;”Arkusz1′”;”!”;”A:BB”);PRAWDA);B$2;0)

    Konstrukcja powyższa (z ADR.POŚR) wynika z tego że nazwa pliku źródłowego jest zmienna i zależy od wpisanej przeze mnie daty (komórka A1).

    1. Post
      Author
  3. Jednak to dobrze spytać specjalistę w temacie 🙂
    Panie Piotrze, a jest możliwość wybrnięcia z tego w mało bolesny sposób? Próbowałem pozbyć się ADR.POŚR i wyrzucić adres do jakiejś komórki (załóżmy że A1) w postaci:
    =ZŁĄCZ.TEKSTY(„‚\\100.100.100.1\katalog\podkatalog\[Raport”;$A$1;”.xlsx]Arkusz1’!A:BB”)

    Ale tutaj wariuje mi funkcja wyszukaj pionowo:
    =WYSZUKAJ.PIONOWO($A4;$A$1;B$2;0)

    parametr: Tabela_tablica wyrzuca #ARG!

    1. Post
      Author
  4. Witam serdecznie,
    Chcę skorzystać z pliku bazowego (zamkniętego), zawierającego pełne dane klientów, do którego odnoszą się łącza w pliku otwartym, używanym przez biuro obsługi, zawierającym jedynie wybrane dane, zablokowane dla przypadkowej edycji.
    Niestety przenoszone m.in. adresy mailowe za nic w świecie nie chcą mi się dać użyć jako takie (osoby z biura wysyłają w starym pliku w ten sposób maile do klientów klikając w adresy mailowe i przechodzą automatycznie do Outlooka.)
    Czy jest jakiś sposób na „zmuszenie” Excela, aby traktował dane w komórce jako adres mailowy?

    Z góry dziękuję za odpowiedź.

    Pozdrawiam
    Marek

    1. Post
      Author
      1. Witam ponownie,

        dziękuję serdecznie, zadziałało!
        U mnie co prawda są tabele, więc funkcja działa mi z nazwami nagłówków.
        Teraz jeszcze muszę powalczyć z tym, że nie aktualizują mi się dane, gdy plik bazowy jest zamknięty. Ale najpierw prześledzę dokładnie ten post …

        Jeszcze raz dziękuję za wskazówkę i powtórzę za poprzednikiem: Podziwiam pasję!!!

        1. Post
          Author

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *