Jak sprawdzić wiele warunków jednocześnie – funkcja ORAZ, funkcja LUB

Piotr Majcher Excel 14 Comments

Jak sprawdzić wiele warunków jednocześnie? Funkcje ORAZ i LUB pomogą 🙂

Funkcja ORAZ potrafi sprawdzić czy wszystkie warunki (testy logiczne) są spełnione.

Funkcja LUB sprawdza czy którykolwiek z podanych warunków jest spełniony.

Obie funkcje w wyniku podają wartość PRAWDA albo FAŁSZ.
Obie funkcje są tak samo zbudowane i potrafią sprawdzić do 255 warunków (testów logicznych) jednocześnie.

Połączenie funkcji ORAZ i funkcji LUB może dawać fantastyczne efekty.

W tym odcinku zobaczysz jak łączyć te funkcje i zagnieżdżać ORAZ i LUB jedna w drugiej aby sprawdzać naprawdę skomplikowane wymagania.

Użyta/e funkcja/e: ORAZ, LUB, JEŻELI

 

Pobierz plik do filmu: http://www.pmsocho.com/pobierz-pliki-do-filmow

Nazwa pliku: excel-760 – Jak sprawdzić wiele warunków jednocześnie – funkcja ORAZ, funkcja LUB.xlsx

 

Comments 14

  1. Chciałbym poszukać pomocy – mam 2 kolumny z których można z listy wybrać po 1 wartości – wartości te tworzą pary: a-b; a-c; a-d; e-b; e-c; e-d;
    dla jednej pary przy wykorzystaniu funkcji oraz i jeżeli komunikat prawda i fałsz z funkcji jeżeli generują się poprawnie jak zapisać funkcje aby wszystkie pary generowały poprawną wersję prawda, fałsz. Dla jednej pary wygląda to tak i działa.
    =jeżeli(oraz(A1=”a”; B1=”b”);prawda; fałsz)
    jak dopisać dalszą część formuły aby przy innym wariancie wyboru A1=”a”; b1=”d” itd prawidłowo generowały się prawda i fałsz?

    1. Post
      Author

      Wykorzystaj oprócz funkcji ORAZ także funkcję LUB, na przykład:
      =JEŻELI(LUB(ORAZ(A1=”a”; B1=”b”);ORAZ(A1=”a”; B1=”c”);ORAZ(A1=”a”;B1=”d”));PRAWDA;FAŁSZ)

  2. Witam serdecznie, Potrzebuje pomocy. Założenie jest takie:
    Jeżeli Kolumna A zawiera 1 oraz kolumna B zawiera „dany tekst” licz 1.
    Z jakich funkcji skorzystać? bardzo proszę o pomoc.

    1. Post
      Author
  3. Dzień dobry,

    Mam taki problem, tworzę kalkulator w którym chciałbym aby było można wybrać źródło (np nbp; cinckiarz) i rodzaj waluty z tego źródła (EUR; CHF; USD; GPB) i chciałbym aby zwracało wartość z określonej komórki z przypisaną wartością kursu. Funkcja jeżeli.oraz musiała by być użyta w jednej komórce kilka razy w sumie 8. Czy nie ma innego sposobu?
    tak wygląda formuła
    jeżeli(oraz(nbp; eur)’wartość z komórki;’brak waluty)lub(jeżeli(oraz….

    1. Post
      Author
  4. witam serdecznie, proszę o pomoc jak stworzyć formułę, żeby zwracała wartość w zależności od 2 parametrów.
    1) wartość pola F2 była większa/mniejsza niż 50000 – wtedy dokonywane są inne obliczenia
    2) wartość pola E2 posiada oznaczenie M/inne – wtedy dokonywane są inne obliczenia

    Obecnie funkacja działa tylko dla 1 kryterium parametrów

    =JEŻELI(F2<=50000; 140+20; 140+20+0,1%*(F2-50000))

    1. Post
      Author

      Cześć Łukasz,
      Proszę opisz dokładnie co chciałbyś osiągnąć i jakie obliczenia mają być wykonywane dla poszczególnych przypadków. Rozpisz kilka takich przypadków, podaj oczekiwane wyniki i wyjaśnij z czego one wynikają to może będę w stanie pomóc.

  5. Cześć, potrzebuję pomocy w stworzeniu formuły.

    W jednej komórce mam możliwość wpisania 5 liczb – 0, 1, 2, 3 lub 4. Chciałbym stworzyć formułę, gdzie Jeżeli wybiorę 0, to wyświetli się wartość „A” lub jeżeli wybiorę 1 to wyświetli się wartość „B” lub jeżeli wybiorę 2, 3 lub 4 to wyświetli się wartość „C”. – w zależności od wybranej wartości chciałbym wstawić inny komentarz.

    W jaki sposób najlepiej to rozwiązać?

    1. Post
      Author
      1. Dzięki za pomoc. Formuła „JEŻELI” z 3 warunkami rozwiązała problem 🙂

        =JEŻELI(O12=0;”Zaplanuj szkolenie”;(JEŻELI(O12=1;”Rozważ zastępstwo”;(JEŻELI(O12>=2;”OK.”)))))

        1. Post
          Author
  6. Witam,
    Bardzo prosze o pomoc.
    Scenariusz: kolumna z dwoma wierszami gdzie obie komorki moga byc puste lub tylko jedna z nich. prosze o pomoc z formula ktora zwroci mi wartosc komorki lub zero gdy obie sa puste.

    Z gory dziekuje za pomoc.
    Lidia.

    1. Post
      Author

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *