Sprawdzanie czy wpisywana wartość spełnia skomplikowane wymagania – formuła

Piotr Majcher Excel 4 Comments

Tylko dla wytrwałych, zaawansowanych użytkowników!

W tym odcinku pokazuję jak sprawdzać czy czy wartość wprowadzana do komórki spełnia skomplikowane wymagania.

Jeśli jest potrzeba aby sprawdzić wiele warunków jednocześnie – mechanizm Poprawność danych pozwala korzystać z formuł przy pomocy których można sprawdzić dowolną ilość nawet bardzo skomplikowanych wymogów.

W tym odcinku buduję formułę, która zawiera 6 różnych funkcji (niektóre użyte wielokrotnie) aby sprawdzić czy wpisywane kody spełniają określone wymagania.

Użyty mechanizm: Poprawność danych – formuła

Użyta/e funkcja/e: DŁ, ORAZ, KOD, LEWY, FRAGMENT.TEKSTU, CZY.LICZBA

 

Pobierz plik do filmu: http://www.pmsocho.com/pobierz-pliki-do-filmow

Nazwa pliku: excel-694 – Sprawdzanie czy wpisywana wartość spełnia skomplikowane wymagania – formuła.xlsx

 

Comments 4

  1. Zainspirował mnie ten film. Mam arkusz i w kolumnie c wpisuję kategorię akt: B lub BC

    Chciałem wprowadzić kontrolę poprawności danych: wielkie B, 1 znak, lub wielkie B, 2 znaki.
    Formuła działa na 2 znaki czyli BE. Gdy wpiszę samo B zwraca #ARG!.

    Oto formuła. Nie oczekuję nawet rozwiązania, ewentualnie wskazania błędu lub formuły do zastosowania.
    =LUB(ORAZ(DŁ(C3)=1;KOD(C3)=66);ORAZ(DŁ(C3)=2;KOD(LEWY(C3;1))=66;KOD(FRAGMENT.TEKSTU(C3;2;1))=69))

    Pozdtawiam – Piotr

    1. Post
      Author

      Spróbuj tak:
      =JEŻELI(DŁ(C3)=1;JEŻELI(KOD(C3)=66;PRAWDA;FAŁSZ);JEŻELI(ORAZ(DŁ(C3)=2;KOD(LEWY(C3;1))=66;KOD(FRAGMENT.TEKSTU(C3;2;1))=69);PRAWDA;FAŁSZ))

    1. Post
      Author

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *